Oleh : Imam A.W., S.Kom., M.Kom.

  1. Buat desain sebagai berikut

  2. Konfigurasi untuk router0

    Current configuration : 617 bytes

    !

    version 12.4

    no service timestamps log datetime msec

    no service timestamps debug datetime msec

    no service password-encryption

    !

    hostname Router

    !!

    !

    spanning-tree mode pvst

    !

    !

    !

    !

    interface FastEthernet0/0

    ip address 192.168.1.1 255.255.255.0

    duplex auto

    speed auto

    !

    interface FastEthernet0/1

    ip address 192.168.2.1 255.255.255.0

    duplex auto

    speed auto

    !

    interface Vlan1

    no ip address

    shutdown

    !

    router ospf 100

    log-adjacency-changes

    network 192.168.1.0 0.0.0.255 area 0

    network 192.168.2.0 0.0.0.255 area 0

    !

    ip classless

    !

    !

    !

    line con 0

    line vty 0 4

    login

    !

    !

    !

    end

  3. Konfigurasi untuk router1

    Current configuration : 617 bytes

    !

    version 12.4

    no service timestamps log datetime msec

    no service timestamps debug datetime msec

    no service password-encryption

    !

    hostname Router

    !

    !

    !

    spanning-tree mode pvst

    !

    !

    !

    !

    interface FastEthernet0/0

    ip address 192.168.1.2 255.255.255.0

    duplex auto

    speed auto

    !

    interface FastEthernet0/1

    ip address 192.168.3.1 255.255.255.0

    duplex auto

    speed auto

    !

    interface Vlan1

    no ip address

    shutdown

    !

    router ospf 200

    log-adjacency-changes

    network 192.168.1.0 0.0.0.255 area 0

    network 192.168.3.0 0.0.0.255 area 0

    !

    ip classless

    !

    !

    !

    line con 0

    line vty 0 4

    login

    !

    !

    !

    end

  4. Konfigurasi untuk router2

    version 12.4

    no service timestamps log datetime msec

    no service timestamps debug datetime msec

    no service password-encryption

    !

    hostname Router

    !

    !

    spanning-tree mode pvst

    !

    !

    interface FastEthernet0/0

    ip address 192.168.1.3 255.255.255.0

    duplex auto

    speed auto

    !

    interface FastEthernet0/1

    ip address 192.168.4.1 255.255.255.0

    duplex auto

    speed auto

    !

    interface Vlan1

    no ip address

    shutdown

    !

    router ospf 300

    log-adjacency-changes

    network 192.168.3.0 0.0.0.255 area 0

    network 192.168.4.0 0.0.0.255 area 0

    !

    ip classless

    !

    !

    line con 0

    line vty 0 4

    login

    !

    !

    !

    end

  5. Konfigurasi untuk router 3

    version 12.4

    no service timestamps log datetime msec

    no service timestamps debug datetime msec

    no service password-encryption

    !

    hostname Router

    !

    !

    spanning-tree mode pvst

    !

    !

    interface FastEthernet0/0

    ip address 192.168.3.4 255.255.255.0

    duplex auto

    speed auto

    !

    interface FastEthernet0/1

    ip address 192.168.5.1 255.255.255.0

    duplex auto

    speed auto

    !

    interface Vlan1

    no ip address

    shutdown

    !

    router ospf 400

    log-adjacency-changes

    network 192.168.3.0 0.0.0.255 area 0

    network 192.168.5.0 0.0.0.255 area 0

    !

    ip classless

    !

    !

    !

    !

    line con 0

    line vty 0 4

    login

    !

    !

  6. Konfigurasi untuk router 4

    version 12.4

    no service timestamps log datetime msec

    no service timestamps debug datetime msec

    no service password-encryption

    !

    hostname Router

    !

    !

    !

    spanning-tree mode pvst

    !

    !

    !

    !

    interface FastEthernet0/0

    ip address 192.168.4.2 255.255.255.0

    duplex auto

    speed auto

    !

    interface FastEthernet0/1

    ip address 192.168.5.2 255.255.255.0

    duplex auto

    speed auto

    !

    interface Serial0/0/0

    ip address 192.168.6.1 255.255.255.0

    !

    interface Serial0/0/1

    no ip address

    clock rate 2000000

    shutdown

    !

    interface Vlan1

    no ip address

    shutdown

    !

    router ospf 500

    log-adjacency-changes

    redistribute bgp 25000 metric-type 1 subnets

    network 192.168.4.0 0.0.0.255 area 0

    network 192.168.5.0 0.0.0.255 area 0

    network 192.168.6.0 0.0.0.255 area 0

    !

    router bgp 25000

    bgp log-neighbor-changes

    bgp redistribute-internal

    no synchronization

    neighbor 192.168.6.2 remote-as 26000

    redistribute ospf 500

    !

    ip classless

    !

    !

    line con 0

    line vty 0 4

    login

    !

    !

    !

    end

  7. Konfigurasi untuk Router 5

    !

    version 12.4

    no service timestamps log datetime msec

    no service timestamps debug datetime msec

    no service password-encryption

    !

    hostname ISP

    !

    !

    !

    spanning-tree mode pvst

    !

    !

    !

    !

    interface Loopback0

    ip address 10.0.0.1 255.255.255.0

    !

    interface FastEthernet0/0

    no ip address

    duplex auto

    speed auto

    shutdown

    !

    interface FastEthernet0/1

    no ip address

    duplex auto

    speed auto

    shutdown

    !

    interface Serial0/0/0

    ip address 192.168.6.2 255.255.255.0

    clock rate 64000

    !

    interface Serial0/0/1

    no ip address

    clock rate 2000000

    shutdown

    !

    interface Vlan1

    no ip address

    shutdown

    !

    router bgp 26000

    bgp log-neighbor-changes

    no synchronization

    neighbor 192.168.6.1 remote-as 25000

    network 10.0.0.0 mask 255.255.255.0

    !

    ip classless

    !

    !

    !

    line con 0

    line vty 0 4

    login

    !

    !

    !

    end

  8. Periksa dengan ip route pada setiap router.

    Contoh daftar routing pada router 4.

    Contoh daftar routing pada router 5

    Contoh daftar routing pada router 2

    Contoh daftar routing pada router 3

    Contoh daftar routing pada router 1

    Contoh daftar routing pada router 0

  9. Uji koneksi dengan ping dari pc 0 ke ip loopback Router 5

    Uji koneksi dengan ping dari pc 1 ke ip loopback Router 5

    Atau dapat juga menggunakan tracert

    Lakukan juga pengujian dari router 5 ke pc 0 dan 1

  10. Beberapa perintah yang dapat digunakan adalah
  • Show ip route
  • Show ip bgp neighbors
  • Show ip bgp
  • Show ip ospf
  • Show ip ospf neighbors
  • Show run conf

 

Untuk memudahkan di ditampilkan gambar dan perintah penting untuk menyelesaikan masalah.